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Risk Disclaimer 

High Risk Investment 

Trading FX or CFDs on margin carries a high level of risk, and may not be suitable for all investors. The 
high degree of leverage can work against you as well as for you. Before deciding to trade you should 
carefully consider your investment objectives, level of experience, and risk appetite. The possibility 
exists that you could sustain a loss of some or all of your initial investment and therefore you should not 
invest money that you cannot afford to lose. You should be aware of all the risks associated with FX/CFD 
trading, and seek advice from an independent financial advisor if you have any doubts. 

Retail Trading Realities Market Opinions 

Any opinions, news, research, analyses, prices, or other information contained on this publication is 
provided as general market commentary, and does not constitute investment advice. Retail Trading 
Realities will not accept liability for any loss or damage, including without limitation to, any loss of profit, 
which may arise directly or indirectly from use of or reliance on such information. 

Internet Trading Risks (VPS) 

There are risks associated with utilizing an Internet-based deal execution trading system including, but 
not limited to, the failure of hardware, software, and Internet connection of your chosen VPS provider. 
Since Retail Trading Realities does not control signal power, its reception or routing via Internet, 
configuration of your equipment or reliability of its connection, we cannot be responsible for 
communication failures, distortions or delays when trading via the Internet.  

Accuracy of Information 

The content on this publication is subject to change at any time without notice, and is provided for the 
sole purpose of assisting traders to make independent investment decisions. Retail Trading Realities has 
taken reasonable measures to ensure the accuracy of the information on this publication, however, 
does not guarantee its accuracy, and will not accept liability for any loss or damage which may arise 
directly or indirectly from the content.  

Please remember that past performance may not be indicative of future results. 
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Copyright disclaimer 

RTR Momentum Trend © (2023) Expert Advisor and all source code are owned by Retail Trading 
Realities Ltd (UK), All rights reserved. 

Any attempt to decompile, modify, reverse compile, reverse engineer or decrypt RTR Momentum Trend 
© Expert Advisor .ex5 file, is prohibited. 

Any individual or any entity (sole traders, LLCs, Ltd companies, websites, online communities such as 
Reddit, 4shared, Discord  and Telegram groups) other than Retail Trading Realities Ltd attempting to 
sell, transmit, host, or otherwise commercially exploit © 2023 RTR Momentum Trend EA is breaking the 
law, i.e. software piracy is a Federal Crime in the USA.  

Where possible, Retail Trading Realities Ltd will take legal action. 

Retail Trading Realities Ltd only sells RTR Momentum Trend © Expert Advisor on MQL5.com, if you 
have received it elsewhere please get in touch. 

 DM me on MQL5.com  
 RetailTradingRealities.com 
 contact@RetailTradingRealities.com 
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Description 
RTR Momentum Trend Expert Advisor for MT5.  

The Expert looks for a Trend and Momentum. 
 
It is Multi-Time Frame (MTF), it uses 3 time frames; Highest Period, Middle Period and Lowest Period. 
There is a 2 Time Frame (TF) option as well. 
The Higher Period – is the anchor timeframe, the expert will look for a trend and momentum on this TF. 
The Middle Period – looks for a pullback (ignored if 2-TF option is true) 
The Lowest Period – is the chart that you attach the EA to (important). Stop Losses and Take Profits are 
calculated from this Chart. 
 
This is a top down system, Higher time frame confirmation, Lower time frame entries, Higher time frame 
exits. Small stop losses and larger take profits. 
 
Momentum - Expert Buy when Higher time frame is already in a well-established up trend. Expert Sell 
vice versa. 
 
RTR Momentum Trend Expert Advisor works best, using diversification, that its’ intended use. EA 
placed on multiple tickers, on multiple timeframes. That way we smoothen the equity curve, reduce 
drawdown, have more trades, better for our statistics. It is suited to tickers that trend. 

Indicators used: 

- RTR Trend ©, a custom in house indicator, is a standard deviation of price indicator, with a few extra 
filters, and better MA Smoothing. 
- Volatility Bands (standard deviations)  
- Multiple moving averages. 
- Angle of SMA, 
- ATR, Average True Range. 
- % of ADR, Average Daily Range. 
- So yes, there are lot of calculations. 
 

Philosophy: 

RTR Momentum Trend EA is inspired by the works of author Michael Covel, traders Richard Dennis, 
William Eckhardt, and Richard Donchian -  Trend Followers. However this EA executes trades on lower 
timeframes, does not rely on the trailing stop for Take Profits (there is a trailing stop), makes no attempt 
to time the markets.   

Trend Following has been unpopular in mainstream financial publications for some time. 

 
Paul Tudor-Jones 03/05/2022 CNBC Interview https://www.cnbc.com/2022/05/03/paul-tudor-jones-says-he-cant-think-
of-a-worse-financial-environment-for-stocks-or-bonds-right-now.html  
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I am predicting that trend following is back, new divergences caused by recent higher interest rates, 
means old correlation models won’t work. We have only just recently come out of a 14 year worldwide 
low interest rate regime in 2022. This EA is for traders who are fans of trend following.  

RTR Momentum Trend EA Features: 

> Magic Number (Expert unique ID). 
> Max Spread Filter. 
> Custom Comment. 
> 3 Time Frame / 2 Time Frame option. 
> Direction - Long only / Short only modes. 
> Position sizing; Fixed Lot, Percent Risk, Fixed Dollar Amount. 
> Profit Threshold, (a multiple of Stop Loss). 
> Day of Week Filter. 
> Time of Day Filter. 
 
 Other : 
> Online/PDF Manual. 
> . set Expert Set files. 
> You must Read the Manual, for RTR Momentum Trend EAs’ intended use. 
> Max, 10 Activations. 
> Works on MT5 Hedging accounts (not Netting). 
> Assumes US $Dollar deposit account. 
 

How does RTR Momentum Trend EA compares with Grid/Martingale : 

Advantages/Disadvantages: 

> No Grid/Martingale. 
> Every Trade has a Stop Loss. 
> Take Profit a lot larger than Stop Losses. 
> Low Leverage is perfect. 25:1 is more than enough. 
> Adds into winners (not losers) 
> Good results on Multiple Time Frame settings. 
> No negative progressive lot size increments. 
> After a loss, next trade risk will be smaller and so on. 
> Ugly Upward Equity curve. (Diversification can smoothen out equity curve - read manual.) 
> Low Win Rate 20%. 
> In a Drawdown 80% of the time. 
> Minimum $10,000 personal Account or Prop Account (on Lowest Risk Setting) 
> Perfect for Darwinex Accounts. 
 
 
If you like what you see, do not Buy Now, download the Demo first, use the MT5 Optimizer using your 
Brokers tick data, Read the EA Manual (all of it). Rent it, then if satisfied purchase the full package. Once 
the EA is activated MQL5.com cannot give a refund. MQL5.com handles all sales / refund process. 
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Welcome 

Thank You for downloading the Demo of RTR Momentum Trend © Expert Advisor (EA) for MT5. 

This guide will demystify the strategy, the EA settings and if you have not used EAs or MT5 before, this 
manual will be an educational introduction to the MT5 Strategy Tester and Optimizations. 

Attach EA to Chart 

MT5 Terminal>File>New Chart> USDJPY 

MT5 Terminal> View > Navigator > to find EA 

     

Either: Drag and Drop EA to Chart or Select EA Right click > “Attach to Chart”. 

Under the Common Tab, click ‘Allow Algo Trading’. 

 

If you cannot find your Ticker Symbol, MT5 Terminal > View > Market Watch…> right click any ticker 
inside Market Watch > Show All,  
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After you have all your desired symbols, return to Market Watch> right click any ticker > Hide All.  

This way Market Watch is not running in the background using up CPU resources, looking at ticker 
quotes you are not interested in. 

(Also While you are in Market Watch > Right Click any ticker> Columns > Spread. Shows all Bid-Ask  
spread in points.) 

You must Attach EA to the chart period, which matches the Lowest Period in EA Settings. So if Lowest 
Period = M15, you must attach EA to M15 chart. 

.set Files (Expert Set Files), How 2 load 

.set files have saved settings, pre-sets.  

.set files will only work for the EA it was designed for. 

I have provided a zipped folder of .Set files, see https://MQL5.com/en/users/PKSN/Publications. 

 

Simply double click on the EA (Teacher Hat Icon) in the top right hand corner, of the chart. 

 EA Settings will open up > Inputs Tab  

Scroll to the bottom of these settings, click ‘Load’. 
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If you want to save your own .set file, click Save. I like to name it like so 
“lowest_timeframe_Symbol_3TF”   “m15_NDX_3TF” meaning EA is attached to Chart Period M15, 
Nasdaq NDX CFD, 3 Time Frame setting. 
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Warning Do Not Set any chart period = ‘current’ 

 
When switching charts, if a signal has just been executed, the algo will make new trades, based 

on the time frame you switched to. If the EA is meant to be on the 15 minute chart, then set 
Lowest Period (‘Second_TF’ in this example to ’15 minutes’), never ‘current’. 

 

How the EA is coded, OnBar( ) vs OnTick( ) 

 

This EA, is coded OnBar() , some programmers call it NewBar(), what that means is the script/code is 
executed once on the Open of  every new candlestick (bar). This is a more reliable when it comes to 
Back testing and true outcomes. The RTR Momentum Trend Expert executes code on every new bar 
opening of input ‘Lowest Period’. 

 
This is in contrast to MT5 default for executing code OnTick(), On Tick means the code tries to execute 
on every new price quote that come in. Each new change in price quote, is called a ‘tick’. It tries, 
because if a code is being executed and a new tick comes in, while that code/script is being processed, 
the MT5 terminal will not execute the code again until a new tick comes in. That is it skips the tick that 
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came in while the code was being processed in a Live Market. However when running a back test in the 
Strategy Tester, MT5 assumes at every tick the code will get executed. 
 
Most martingale/grid, tick Scalping EAs on the market place are coded ‘OnTick()’, which can be 
problematic, in a real live trading . 
 
https://www.mql5.com/en/docs/event_handlers/ontick  - it’s really not that interesting. 
 
How the EA is coded – Magic Numbers 
 
Almost all EAs have an Expert ID called Magic Numbers.  
Set this in the Inputs option of your EA. 
Magic Numbers should be at least 6 digits long.  
They should be integers (no decimals) i.e 1234567890. 
No Characters AaBbCcZz!”?^%. otherwise EA will catch an Error. 

 

Magic Numbers are important so MT5 terminal can distinguish, which trades belong to which strategy.  

A strategy is - every time you attach an EA to a Chart. Every time you attach an EA to a Chart, make 
sure you give it a new Magic Number i.e. 7879532, 6547023, 999111. 

You also need to keep note, of which strategy has what Magic Number. 

Magic Numbers are important to this EA, users are expected to have multiple strategies. The RTR 
Momentum Trend Expert Magic numbers are used to monitor, adjust and close out positions. So if 2 or 
more strategies have the same Magic number, all trades will be closed out at the same time and we 
don’t want that! 

To view Magic Numbers of your trades, in the MT5 Terminal > View> Toolbox > Trade (Tab )> right click 
cursor anywhere on the Trade Tab > Columns > Magic Number. 
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Strategy Tester & Optimizer in MT5 – What is it? 

MT5 Terminal > View > Strategy Tester 

  

To back test an Expert Advisor, you can run a Single tests, and Optimizations in MT5 Strategy Tester.  

Optimizations will look at the input parameters (see Inputs Tab of Expert) you have selected and all the 
values you wanted the EA to be tested for. It will test all possible combinations of settings. Be careful it 
is recommended you choose only up to 3 inputs for optimization. The more inputs selected the more 
chance of ‘curve fitting’.  

If you choose too many inputs and step settings, i.e. 2,000 combinations, MT5 will revert to a ‘genetic 
algorithm’, to find best settings, it won’t test every combination. It will test a sample and try to find the 
best settings using their in-house secret algo. 

 

Choose Symbol and the Chart Period you would have placed the Expert Advisor on, if it were live 
trading.  

The Yellow Dollar sign Icon  is very important, to new users of MT5 strategy tester.  
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You will need to click on this Icon, to change the selected Symbols’ defaults for a correct back test. Its’ 
default is either; (No Leverage) ‘CFD’ and ‘Forex No Leverage’. Here you will change it to ‘CFD Leverage’ 
or ‘Forex’.  

 

You can also change the default Direction from ‘Full Access’ to ‘Long only’ or Short Only’, this change in 
direction set here, will only work for back tests and optimizations, this will not change in Live or Demo 
trading.  

 

Modelling Data: using Open Prices (the RTR Momentum Trend Expert is coded On Open Prices –
OnBar() ), or simulated ticks called ‘Every Tick’, ‘Every tick based on Real Ticks’ include Broker historical 
Bid-Ask Spread, there is also a 1 minute bar option for the data.  

Note: Back tests that have Real Tick selected will take a lot longer than on ‘Open prices’ modelling. 

I suggest Optimizations using ‘Open Prices’, then Run Single Back test using ‘Real Ticks’. 

 

START, STEP, STOP: 
START, is the first value of the input that will be tested. 
STEP, is the increment, it will add to the previous value of the input that was tested, and will run a new 
test.  
STOP, is the Last value of the input that will be tested for. 
 
So in this Example we have selected only 1 input for Optimization, Profit Threshold. 
We Start at 8, STEP (increment)= 2, FINISH at 20. 
 
We will test Profit Threshold at; 8, 10, 12, 14, 16, 18, 20.  
And there are 7 Passes (8 to 20).  
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Source: https://www.metatrader5.com/en/terminal/help/algotrading/strategy_optimization  
 
 
How 2 optimize this EA using ‘Open prices’ in MT5 Strategy Tester 
 
I would only optimize for a maximum of 3 inputs: 

 Middle Period (ignored when in 2 timeframe mode), 
 Lowest Period, 
 Profit Threshold (this must always be a selected input in an optimisation) 

 
I would keep Higher Period fixed equal to Daily D1 or Week W1. 
 
Optimizing for the other inputs such as Direction and Day of Week, Hour of Day filters, will be discussed 
in the next section. 
 
I optimise using the following settings pictured here,  
Modelling:  Open Prices or 1 minute OHLC bars 
 
Slippage: choose 30ms,( my VPS has a Ping of 8ms) ,this is ignored when using Open Prices modelling, 
but will be used later in Single Tests. 
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Select ‘Fast Genetic Algorithm’ and ‘Profit Factor’. 
 
If my Ticker has several profitable results in the optimiser, I will choose a handful of results and Run 
Single Tests using “Every Tick Using Real Ticks”, just right click on the result and “Run Single Test”. 
 

 
 
“Every Tick Using Real Ticks” is the historical data feed from your broker, with Bid-Ask Spread at every 
tick, where there are gaps in the data it will be filled with “Every tick” which are simulated from 1-
minute OHLC Bars . (For more info MQL5.com help section should have the entire science of it). 
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The ‘Every tick using real ticks’, will take some time, as it is more detailed. This result will always be 
worse than Open Prices Modelling; here we had Open Prices $203k vs Real Tick $149k profit, from a 
$10k deposit. Do not fear too much, I have actually found the real executions are near to Open Prices 
modelling. However we have to think of worst case scenarios, rather than be too hopeful. 

Optimization - use StrategyQuant.com’s ‘Quant Analyzer 4’ to filter Days and Hours  
 
https://StrategyQuant.com  > download and install Free version of ‘Quant Analyzer 4’. I do recommend 
eventually purchasing the Pro Version for any one serious about algorithmic trading. 
 
Export your Report from MT5 Strategy Tester by right clicking anywhere on the ‘Backtest Tab’, make 
sure it is .html file. 
(MyfxBook.com, also has an excellent analysis tool unfortunately does not work for MT5.) 

‘Quant Analyzer 4’ will provide extra Statistics for your strategy, such as Monte Carlo simulation, 
Analysis by direction, merge tests into a Portfolio, too many to mention, they have it covered. 

  Click this, locate your .html file and follow the instructions. 

 

 We want Trade period by open time. 

Example GBPUSD back tests were successful with a 5yr return of 78.63%, however Trades opened on 
Monday, Tuesday, Wednesday we unprofitable and gave us Drawdowns. All of our profitable trades 
came from Thursday and Friday. So we return to our EA Inputs and make Monday, Tuesday, Wednesday 
= False. And Run our Tests Again. We now have a better returns, better drawdowns as well. 
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GBPUSD Optimizations (before Filtering Days). 
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Filter Day Inputs:

 
GBPUSD Optimizations (after Filtering Days), all results are better: 

New Single Test on same settings, with new Daily filters: 

 
 
Monte Carlo simulation in a few clicks using ‘Quant Analyzer 4’:
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Both MT5 and FXBlue.com have an hourly and daily trades summary statistics, however they only report 
on when trades were closed. Which is not helpful, we want to know when to open trades. 

Optimization - use ‘Quant Analyzer 4’ to filter Direction. 

You can use Quant Analyzer 4 to filter for direction. 

I would not filter for direction on tickers that were unprofitable in a standard test that used both 
directions. 

 

How this EA is intended to be used – multiple strategies 

The RTR Momentum Trend © Expert Advisor, is intended be used across multiple tickers/symbols and 
multiple time frames. The reason for this is that we should never rely on 1 ticker symbol, back tests are 
no promise of future results.  

Diversification, the more RTR Momentum Trend © strategies we add to our  MT5 Terminal, we must 
lower our risk on each strategy, we must never have more than 20-to-1 leverage at any time, so that 
includes if all strategies are executing trades on the same day. Diversification reduces maximum 
drawdown. 

Diversification – reduces drawdown Portfolio example 
 
The more uncorrelated strategies added is likely to reduce drawdown. 

Using ‘Quant Analyzer 4’ in a few clicks you can create portfolios, see your new reduced maximum 
drawdown. 

 

As explained before, load around 4 to 5 MT5 Strategy Tester tests (.html files) into Quant Analyser 4. 
(Make sure they all cover the same Date Time period - they don’t have to but better). 

I have loaded 4 strategies NAS100, BTCUSD, GBPUSD and lastly XAUUSD (GOLD).  
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As you can see above image, the last Strategy I loaded was XAUUSD. 

Now focus on the bottom Panel 

 

 

 

 

 
Notice Max DD % of all strategies is 59.8%, 

mean average DD is 41.65% 
Select All (strategies you want in the portfolio) 
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 Click this, it will merge all 4 strategies and take you to the Portfolios Tab. 

Now it is a portfolio with Max DD of 24.9%, a reduction from an average of 41.65%. 

 
 

  
Double Click this blue text $261244.07 (Net Profit) 

 
 
 
 

 
 
Now the XAUUSD (Gold) overview is no longer showing, now it is the Portfolio Overview, CAGR 49.75%: 
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  > Click Equity Chart Tab 
 
 

 

 
Turn on Drawdown, Select % 

 

 
 

to see % DD in a time series. 
 

 
 
And ‘Hey Presto!’ 

 
 
 
About those ‘uncorrelated strategies’ > Click on Portfolio Correlation Tab, to see if you strategies a 
positively or negatively correlated (we want negative correlation in diversification, otherwise too much 
risk). 
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How to use with prop firms 
 
Since Prop Firms no longer have a time limit, how I would use this for prop firms, is to look at my 
predicted Maximum Drawdown over at least a 5 year back test. And divide that by the Maximum Loss 
permitted by the prop firm, 10% for most, so if my maximum predicted DD is 24.9%, then I will divide 
my risk percent per trade further by 3.00, though this would be very slow. 
 
You can also look at your back tests and see where your portfolio of strategies, peak at draw downs , in 
the previous example drawdown stayed under 18%, so getting in when DD is at 9% and then copy those 
trades to your prop account, once that DD Threshold has been met. Does that make sense? 
 
(I have a more suitable M5/M15 Intraday EA for the GBPUSD pair for Prop Firms, it has been on a low 
DD winning streak since January 2022. I will put it up for rent. So check my MQL5 profile.) 
 
 
Psychology – mentally dealing with drawdowns 
 
This strategy has a low win rate, around 20%, which means you spend 80% of your time in a draw down, 
you can have a series of losses, consecutive losses, especially when you have multiple strategies. They 
can be all losing at the same time. Winning Streaks come quickly. So if you get cold feet or shaken out 
during the drawdown and stop trading the EA, what is likely to happen is that you will miss the winning 
streak. This EA does not Attempt to time the market.  

Hopefully you have optimised, back tested and imported those tests into a program like ‘Quant Analyzer 
4’, combined them as portfolios and know what to expect in terms of series of losses, Average DD and 
Maximum DD. 
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EA Settings: 

 

If 2 TimeFrames Only = true, then Middle Period will be ignored. You only have to optimise for 
Highest and Lowest Period. 

The Lowest Period is also, the Chart you must attach the EA to. So in this example above Lowest 
Period is 5 minutes. Attach this EA to M5 chart. Warning never set any period to “current”. 

 

 Fixed lot size, will be skipped over if ‘Risk% per Trade” or ‘Fixed Dollar amount’ is true (>0.0) 
 If you do not want to use Risk % (percentage of Account Balance) must set it to 0.00 
 If you do not want to use Fixed $Dollar Amount per trade set it to 0. 

 

How to set - Risk percentage %, 

‘Risk % per trade’ is the recommended setting for this EA, it equal to percentage of Account Balance. I 
have included other options, ‘Fixed Lot size’ and ‘Risk Dollar amount’, i.e. if you want to risk $200 a 
trade. 

A Strategy is every time you attach the EA to a Chart. So if I have 7 charts with an attached EA, I have 7 
strategies. 

How to set each EA ‘Risk %’ percentage settings: 

Number of Strategies Risk_percent % 
(recommended 

settings) 

 Risky Settings (are 
double the 

recommended) 
1 0.5                        1.0 
2 0.5 ÷ 2  =      0.25                            0.5 
3 0.5 ÷ 3 =       0.167  0.333 
4 0.5 ÷ 4 =       0.125                         0.25 
7 0.5 ÷ 7 =       0.071  0.142 
n 0.5 ÷ n =       ….  1.0 ÷ n =            …. 
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The Risky setting of initial 1.0%, is the maximum risk I am willing to use on this EA. I would not use the 
risky setting on STOCKs as there are Gap up and Gap downs. 

Fixed Lot Size, $Fixed Dollar Amount. 

You will have to set this yourself, just know that you can have 6 open trades on each strategy and we 
want to keep leverage well under 25-to-1. 

I don’t want you to use this, but was suggested by my testers. I feel that using risk percentage of balance 
is the best, because it stakes more as the strategy earns profits and stakes less when the strategy is 
losing. The whole point of automated trading is to do less. Using these options one would have to re-
calculate often. 

Magic Numbers (Expert ID) 

Every time I attach the EA to a new chart, I must give it a new unique Magic number. Any whole number 
(integer) at least 6 digits. 123456789. (No Letters or characters). 

Direction – Both/Long/Short 

Just set the Direction.  

In the Experts Tab of ToolBox on MT5, you will get a printed message, indicating that: 

 “SELL Trades Only, symbol=USDJPY, period=M30, magic=123456”, when the Expert tries to Buy. (Vice Versa). 
Depending on what Direction you have set it to. 

How to set Maximum Spread filter, with examples. 

The Brokers I am using is Darwinex and RoboForex (for Crypto). 

Setting the Maximum Spread is sensitive to your broker. I like to use maximum of = 3 × normal spread. 

Normal spread is just an approximation, of spreads during London-NY trading hours.  

How to find your spread in MT5 Market Watch. 

MT5> View> Market Watch, right click any ticker> Columns > Spread,  
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Here spread GBPUSD = 6 so, set Maximum Spread Filter = 3 × 6 = 18. 

This will help you find average spreads:  https://www.myfxbook.com/forex-broker-spreads  
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Optimized Results Examples 
USDJPY ,  

Date: 01 Jan 2018 – 15 Sep 2023 
Deposit:  $10,000 
Delays : 23ms (only used when Real Ticks selected) 
Modelling: On Open Prices 
 

Fixed Inputs : 2 Time Frame = True, Direction = Long Only, Risk percent =1.0% , Middle Period = ignored 
n/a, No Day/Time Filters, MAX spread filter 25. 

Optimized Inputs: 

Highest Period  = 1 Day, 1Week  .                      2 passes 
Lowest Period   = M30, H1, H2, H3, H4 .           5 passes 
Profit Threshold = 8, 10, 12, 14, 16, 18.            6 passes 
Total of 60 passes. 

 

The top result yielded a profit of $251k from a deposit of $10k, however we need to do a ‘Every Tick 
using Real Tick Test’ single Back Test, we will need at least 95% tick data history quality. 

Real Tick test with broker historical bid-ask spread: 
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Conclusion: $231k profit with, 99% History Quality data, less than $251k open prices modelling. A good 
result, using low leverage less than 20-to-1. 

 Download the Demo and Repeat the above Optimization, Try it yourself. 

NASDAQ -NDX CFD Example 
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We select top result $46k profit for Real Tick Back Test: 
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Conclusion: Real Tick was less than $46k vs $44k profit, a good result.  
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How to setup EA with a Windows Server VPS 
Windows Server 2012/2019/2022 

Summary: Windows Server 2012 – is like Windows 7 PC, Windows Server 2019/2022 – is like Windows 
10 PC. 

I use ForexVPS.net, FTMO users can get 20% off, one must log in to FTMO for this and get the discount 
code from User Area. 

My Affiliate link: https://www.forexvps.net/?aff=47433  

I also recommend https://www.mql5.com/en/vps, fastest ping. 

Download and Install your MT5 like you would on a Windows 10/11 PC. 

 

Copy my Settings: 

MT5 Terminal > Tools> Options > Charts 

 

MT5 Terminal > Tools> Options > Expert Advisors 
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MT5 Terminal > Tools> Options > Server 

 

MT5 Terminal > Tools> Options > Community 
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Final VPS step: 

Once you have all Charts, Time Frames and Symbols you want use in view, go to View>Market Watch> 
right click any ticker, click > ‘Hide All’. 
This will stop MT5 reading quotes in the background, from tickers/symbols the EA is not trading on.  

 

MT4/5 AUTO START for VPS: 

 

I am using ForexVPS.net, and they have this feature, where you can use 
their .exe program to Auto-Start all of your MT4/5 Terminals every 
time the server restarts. Remember You will have to restart your 
Server every now and then, but also your VPS provider will restart 
servers for maintenance. 
 
You will have to enable this manually by reading the steps in the .ODT 
text file (usually on the Desktop). 
 
Other Forex VPS providers also have this feature (nearly all of them). 
 
You won’t need to do this if you have a server provided by 
MetaQuotes from MQL5.com . 
 
Do not use a Linux server with MT4/5. 
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Resources 

RetailTradingRealities.com  

I have no affiliation with the following, just value their content. 

https://www.trendfollowing.com/   
Author Michael Covel, is the historian and a devoted champion of Trend Following.  
 
https://alphaarchitect.com/2015/08/avoiding-the-big-drawdown-with-trend-following-investment-
strategies/  
Alpha Architect article on trend following and diversification, Wesley Gray, PhD 
 
https://www.cis.upenn.edu/~mkearns/finread/trend.pdf  
Cole Wilcox, Eric Crittenden, Blackstar Funds, LLC, Does Trend Following Work on Stocks? (TLDR: Yes) 
 
https://www.youtube.com/@Darwinexchange  
Darwinex, UK FCA broker, Martyn Tinsley, has the best algo optimization series on YouTube. 
 
https://www.mql5.com/en/articles  
Keep up to date with the latest libraries and features of MT5. 
 
https://www.youtube.com/@FinancialWisdom  
A retail trend follower, he reads a lot of Finance books and presents a bite-size summary.  
 
 
 
 


