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Allow EA Web Requests

MT5 Terminal > Tools> Options> Expert Advisors (Tab)

1 Strategy Tester Agents Mansger

MetaCiuote: Language Editor =
DS CpenCl Evnts . Nobfcatird
k Manager

, Glokal Varables

> type in “https://momentum-trend.com”, then Press OK.

Allow WebRequest for isted URL:

@ momentum-trend.com
@ https: //momentum-trend.com
+ | https://

Expert Advisor Directory

File > Open Data Folder > MQL5 > Experts> put your Expert Advisor (EA) in this folder.

ﬂ 4000021697 - Darwinex-Live - Hedge - Tradeshde Trading Tech Limited -
) o0EEM View Inser  Charts  Tools Window Help = | BCICAATIDICITUIDDADBRSITIBRS02S - o x

M
i ) Hom Share Vigw
New Chart * BigoTrading (%) New Qi “ ins i L
Open Deleted L4 M e oy 4 i i Setect
N . Ma R 4| L - ..
Profiles » Pinto Quick Cop . L = Hew Properties
- access ? folder - v i
= Close Ctri+F4 Chpboard Rt N Open elect
() Save CtrlsS ? « Term... » 6C3CBATIDICITHIDDANBFASAZIERS.. v P
[E Save as Picture A I Name Dote modified :
@& CneDrive - Personal L1 Mam L .
B Open Data Falder Ctrl+Shift=D bates : F

v B This PC

config

& Print Ctrl+P 3D et lags
[ Desktop .

Print Preview O maws

o Documents piibles
& Print Setup & Downats -~

t Open an Account Jt Music Tester
| Pictures IO
B videos

‘e Local Disk (C5)

"
& Login to Trade Account . USB Drive (E)

& Loginto Web Trader

w USB Drive (E)
= Login to MQOL3.community
ik Network

<l Exit

>Open Data Folder ‘Ctrl+Shift+D’
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Home Share View (7]
o
P Properties
Clipboard Organize Hew Dpen
[ VN « GCICEAT1IDICITOIDDLDBFA5421B.., » MOLS v @ 1 3 L
RTR_Momentum_Trend_EA_Masdag * [] Mame
set_files [0 | Experts
set_files Fles
set_files Images
Include
o OneDrive - Personal
Indicators
= This PC Libraries
>MQL5 Folder
1 MQL5 » Experts v O earch Expént ol
Momentum_Trend_EA_Nasdag * [] MName Date modified Type
ples Advisors
iles Examples
les Free Robots
Licensing
ive - Personal
Market
2 Red Fairy NN EA
bjects RTR_LTD
top testingd
testing3
iments :
testing
nicads =
testing123
c B RTR_Momentumn_Trend_All
>Experts Folder :
MT5 Terminal> View> Navigator> Expert Advisors
B 4000021697 - Darwinex-Live - Hedge - Tradeslide Trading Tech Limited - [AUDUSD H1]
g File Inset  Charts  Tools  Window  Help
v v [{ Languages * boTrading | [} NewoOrder | (1|00 4t | @ @ FH | 43l Wle
M1 Mi  Toolbars e 4|4 - S =T S
Nawigator), ¥ Status Bar | =
% Darwi ¥ Charts Bar &
&2 Al
in Symbols Ctri+U
£ Ex Depth OF Market !
| ¥ Market Watch Ctri+M
+ Data Window Ctri«D
B Navigator CtreN
= Toolbox Ctrl-T
I} Strategy Tester Ctrl+R
£ Chats Alt+M
" 5 Reports AltE
" Fullscreen 1
B Version2
Version3
Versiond
wTailing_TP
www

= Momentum_Trend_Crypto
[ Momentum_Trend_Gold
B Momentum_Trend_Nasdag

1 Youtube

testing123

Comman | 7

M3 | AUDUSD H1 [

Now File> New Chart > “find your chart symbol e.g. USDJPY” > drag and drop EA from Navigator onto
the chart>check Allow Algo Trading> "type in your password” (required) > click load> Load SET file
usdjpy_m15 > change chart time frame to M15.
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ﬂ 4000021697 - Darwinex-Live - Hedge - Tradeslide Trading Tech Limited - [AUDL

NI View et Chats Toos Window Help Note: Every time you load an EA onto a
- EECEEEE /oo pe | Chart you must give it a new Magic

\  OpenDeleted ’ AUDCHF .
] pons v AUDRY Numberi.e. 56823798.
':: Close Ctri+F4 AUDUSD
4 (L) Save CirlsS  AUDNZD . .. . .
| B9 Seveas Piciure B Magic Number is in the inputs tab; make sure it
" 1 openpataroier  cuteshitee [ is at least 5 digits long.
& Print CurteP :‘#“ Every Instance of an Expert Advisor must have a
5
L s new unique Magic Number.

Ir@ Print Setup

3
L
L3
Commodities *
L3

So that there is no confusion between strategies

that have the same symbol, but not necessarily
the same settings.

4+ Open an Account Custon

£ Login to Trade Account
@ Login to Web Trader
F= Login to MOLS.community

€] Exit
| waww
.-Mc-l;l'nlul:\_h:ml_f'cna 13 = _)(
Common  nputs
Vi value ~
Licensng
Proesword (feguned) fe——
Emad {ootonal) ry_emad @emad.com
Bipert D
1 ExpertiD Magic Number FEEAIIL
Time Frames
2 TrmtFegente Oréy Tase
# righest Period 10ay
& padde Period AHours
# LowestPened S Mras
Lot Sme
i Froedd Lot sre. a0
Risk % Lo
. 1 Fucerd Dollar Amount a
> drag and drop EA from the Navigator it
Vi Prafit Theshelst 0.0
onto the chart . or S -
Custom Trade Comment
cuttaes camemant
Soreat Fitm
91 Madmum Spread 0
o Sippage 3
Ewecution Type
& mxscution Markt_crdars
Limit order Satsnge
% it offemt Lo
01 expiraton hows) 1
Day of Week Fiter
P - ]
L it v seie E
o Cancet Fornt I_

[[] Allow modification of Signals settings

> check “[ JAllow Algo Trading” I

(Common Tab).

click “Load”

» Load the SET file for your symbol
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= 13 2 TimaaCeaman Cunles _fales =Y
E Open X
“— A « RTR_Momentum_Trend... > set files v 0 o
Organize v New folder == w M | 0
£y Name Date mo
s Quick access
usdjpy_m15_28052024.set 28/05/2024 15:32 SET File
B Desktop IPy_m -
gbpusd_m15_28052024.set
¥ Downloads eurjpy_m20_28052024.set
Documents chfjpy_h1_28052024.set
& Pictures

| audjpy_m15_28052024.set 28/05/2024 15:4 SET File

RTR_Momentun usdjpy_h1_28052024.set

set_files
set_files
cat filac Ve IS >
File name: | usdjpy_m15_28052024.set v | |Expert Set (*.set) v
_T"—'—'_ T Temi® nleab Tm —

» Now change the Time Frame of the Chart to match the SET File name, i.e usdjpy_m15, must
be placed on M15 chart. Right click on the chart > Timeframes > M15
o Note if you have multi symbol EA - an Expert Advisor that trades multiple Symbols
from 1 chart . Please drop the EA onto a Forex 5 Minute Chart. Thank You.

¥, Hiz L fan Mior u

@ Buy Limit 0.01 157.012

Trading b

=31 Depth Of Market
%] One Click Trading
£ Object List Ctri«B

= Expert List Al

It BarChart A1
il Candlesticks

Line Chart

Templates b ME

- Refresh

Alts2
Alt=3
1 Minute

5 Minutes

Type

buy

] buy
o buy

Volume
0.4
0.65

0.67

170331
170435
170.597

Price

a: 35 974.55 Free Margin: 82 998.11 Margin Level: 330.71 %

Defauit

2024.05.27 21:00 | O:

% Docked
HH Gnd

¥+l Auto Scroll

tb+ Chart Shift

it Volumes
it Tick Volumes
Trade Levels

Trade History
&, Zoomin
& Zoom Out
5% Step by Step
[ saveas Picture

i Properties

M30 30 Minu
Alt<D e
£
CtriG Minutes
H1 1 Hour
Ha 4 Hours
Cir+K Hours
CtrleL D1 Daily
1 Weekly
1 Monthly
. Bp Magic
I 671894
671294
671894
F12
5803.83
| A Market ) Tester
F8 Js6.a68 | v 690 il 24.16 ms
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That is done, now you must change the risk in all SET Files. (Please Read the manual)

Change Risk Settings
Lot Sizes
Y Fixed Lot size 0.0
01 Fixed Dollar Amount 0

- - A sm Nas b

The ‘Risk %’ input is the percentage % of account balance the EA will risk per trade.

1.0 =1.0% is the absolute maximum risk and should only be used if you are trading only 1
symbol i.e. GOLD/USD.

If you are trading 5 symbols (that is 5 charts with attached EAs) then the “Risk %” input on
all Charts should be absolute maximum = 1% < 5, which is equal to 0.20

You would type in “0.20”, Risk % =0.20.
| am only using half of that, in my main Index Signal.

For Crypto | am using full Risk of = 1% = (number of symbols) , however | have a smaller
initial deposit, that is 5 times smaller than my deposit for my main Darwinex account (non-
crypto).

| EEE N A L Aot 170 PV

; Lot Sizes
‘ '/ Fixed Lot size 0.0

!01 Fixed Dollar Amount 0
I .

- - s m e las &

Okay, now you can enjoy your trading.
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Add Symbols to Market Watch Can’t Find your Symbol, stock ticker, Chart?

If you cannot find your Ticker Symbol, MT5 Terminal > View > Market Watch...> right click any ticker
inside Market Watch > Show All,

4000017480 - Darwinex-Live - Hedge - Darwinex - [EURUSD H} Market Watch: 15:90:44

4000017480 - Darwinex-Live - Hedge - Darwinex - i Of File View Inset Chats  Tools  Window Symbal - Bid Ask
90 File Insert  Charts Tools Wi ~v @MW f @& | O agoTading [ '
; : 3 AA 2508 2321
~ v [i  languages 4 M1 M3 Mis oo il s Of wi oW ifRR) RS X 1
! Market Wabch: 163911 ] u AAP 5190 8207
M1 ME Toolbacs » Symbol - Bid Ask Spread € |y aapy 17566 17!.61
Navigator | ¥ Status Bar 4 P £ e Piter 8 e e 1:;-.“"
. 1 e RLHE ~ Chart Window P ' g ﬁ by
A
1« Charts Bar " USDPY - Tick Chart 6 i i
=" . + clickto add.. | E3 Depth Of Market Alt+B 2 ACM 262 i
o [¥] Symbols Ctrl+U Options Beard ~ ACN EIEE TV
ificati 2 s46.00
Depth Of Market 4 8 S i i el :
) Popup Prices F10 2 ADI 175.76 1763
! - - ADM 7420 745
T, Market Watch Ctri+M S st . ADP 4807 02
b Hide All
g cutsD oo lae =
§ u AFP 74,52 7#5(;
|| Navigator Ctrl+N B Symbols Rhtel u AES 1307 1308
— Sets " - AFG 1105 14
=) Toolbox Ctrl+T ot . i e i
1 {:} Strategy Tester Ctrl+R Use System Colors AGLO 122564 123\-5?
= i “ AlG 6126 6188
1S Chats Alt+M e - A 1579 470
s pe ko S Eped - AIG mw 24
| @0_ Repoﬂi Alt+E ¥ Auto Amange : m 108.62 1 3¢
¥ Gnd « AL 3672 L7 AT
. P |
- Bl " Fullscreen . ] 2 ALB 16420 teast
3 F10 testinal, — akcl - =

After you have all your desired symbols, return to Market Watch> right click any ticker > Hide All.

This way Market Watch is not running in the background using up CPU resources, looking at ticker
qguotes you are not interested in.

(Also While you are in Market Watch > Right Click any ticker> Columns > Spread. Shows all Bid-Ask
spread in points.)
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How to setup EA with a Windows Server VPS

Windows Server 2012/2019/2022

Summary: Windows Server 2012 — is like Windows 7 PC, Windows Server 2019/2022 — is like
Windows 10 PC.

ForexVPS.net Offer: https://www.forexvps.net/partner/retailtradingrealities

We also recommend https://www.mql5.com/en/vps, fastest ping.

Download and Install your MT5 like you would on a Windows 10/11 PC.

ﬂ 4000017480 - Darwinex-Live - Hedge - Darwinex - AUDJIPY,M15
File View Inset Charts QRGIIEE Window  Help

R+ + —o d/a .{} [¥] New Order F9| H4 DI W1 MN

~ v |§ v [B] | DE @ | L} Strategy Tester Agents Manager F6an | @ B | =] e ng

A IDE MetaQuotes Language Editor F4 s _ a
BA Task Manager F2

BE Wi XAUUSD, M5: Gold vz US Dol

<-° Global Variables 3 ¥, M1S: Australisn

Copy my Settings:

MT5 Terminal > Tools> Options > Charts

[
| Options ? X
Server Charts Trade ExpertAdvisors OpenCL Events MNotificaions Emal FTP Community Signals

[l chart color print

Show trade history

[ show trade levels
Disable dragging of trade levels =

[APreload chart data for open positions and orders

[[] shaw object propertes after oeation

[[] select object by single mouss dick

[:] Predise time scale

[ select object after creation

Magnet senstivity: : 10 v-

Max bars in chart: | 200000

I =

MT5 Terminal > Tools> Options > Expert Advisors
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| Options ? %

Server Charts Trade ExpertAdvisors QOpenClL Events Notificatons Emal FTP Community Signals

7] Alow algorithmic trading
A Disable algorithmic trading when the account has been changed
[+ Disable algorithmic trading when the profile has been changed
[Coisable algorithmic trading when the charts symbol or period has been changed
A Disable algorithmic trading via external Python APT
4] Allow DLL imports (potentially dangerous, enable only for trusted applications)
[ alow webRequest for listed URL:
|+ add new URL ke https: /fwsw.mal5.com’

I =

MT5 Terminal > Tools> Options > Server

Options ? b4

Server Charts Trade ExpertAdvisors OpenCL Events Notificabons Emal FTP  Community Signals

Password: | eesssssssnss m

[CJEnable proxy server Proxy..,
[ eep personal settings and data at startup

1 [CJEnable news

I News languages: Change

MT5 Terminal > Tools> Options > Community

| Options ? X

Server Charts Trade ExpertAdvisors OpenCL Events Notifications Emal FTP Community  Signals

MQLS.community is an offical community of developers and service providers for trading platform users.

Lagn: | eat 1
Emai: | ; . |

If you have an account, pliease login

Specify services that you want to use in the terminal:

1 [Ccalendar [ codebase
[COMarket Owes
[signais [CJPython integration
[ artdes

o 1 concd || beo
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Final VPS step:

Once you have all Charts, Time Frames and Symbols you want use in view, go to View>Market
Watch> right click any ticker, click > ‘Hide All’.
This will stop MT5 reading quotes in the background, from tickers/symbols the EA is not trading on.

O) File View Insert Charts Tools Windew H

~- (@ 8| oE B @ | OAgoTading [
M1 M5 MI5 M30 | HT H4 D1 W1 MN w1
Market Watdh: 16:39:11
Symbol = Bid Ask  Spread I.
e =5
4 GBPUSD sl 8
2 USDCHE “~ Chart Window 6
2 USDIPY - Tick Chart 5
lick t [E5 Depth Of Market Alt+B
Options Board
= Specification
[ Popup Prices F10
Hide All
§| Symbols Ctri+l
Sats »

MT4/5 AUTO START for VPS:

We at Retail Trading Realities are using ForexVPS.net, and they
have this feature, where you can use their .exe program to Auto-
Start all of your MT4/5 Terminals every time the server restarts.
Recycle Bin 'fﬁrja Remember You will have to restart your Server every now and then,
o but also your VPS provider will restart servers for maintenance.

il You will have to enable this manually by reading the steps in the

dm' .ODT text file (usually on the Desktop).
MT IC Ma

SERERURENAE Other Forex VPS providers also have this feature (nearly all of

them).

You won’t need to do this if you have a server provided by
MetaQuotes from MQL5.com .

Do not use a Linux server with MT4/5.
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Strategy Tester & Optimizer in MT5 - What s it?

MT5 Terminal > View > Strategy Tester

4000017480 - Darwinex-Live - Hedge - Darwinex
ol File Inset Charts Tools \

~ v E Languages * be

M1 MS Toolbars Sl
Status Bar
Charts Bar

Symbols Ctrl+U
Depth Of Market ’

%, Market Watch Ctrl+M
4 Data Window Ctrl+D
H= Navigator Ctrl+N
= Toolbox Ctri+T
B Strategy Tester Ctrl+R
5 Chats Alt+M
(3 Reports Alt+E

" Fullscreen

r% L B v v
dll, iy wWl & Sk
U™ TUAR S A
T b % - ¥ e
=t m....nu;n”ﬂlil]” 3 ) - ——
Single Indicator Visualize Stress & Delays Complete Genetic Forward
optimization optimization optimization
5, open prices, 2022.01.01 - 2023 10.07

To back test an Expert Advisor, you can run a Single tests, and Optimizations in MT5 Strategy Tester.

Optimizations will look at the input parameters (see Inputs Tab of Expert) you have selected and all
the values you wanted the EA to be tested for. It will test all possible combinations of settings. Be
careful it is recommended you choose only up to 3 inputs for optimization. The more inputs selected
the more chance of ‘curve fitting’.

If you choose too many inputs and step settings, i.e. 2,000 combinations, MT5 will revert to a
‘genetic algorithm’, to find best settings, it won’t test every combination. It will test a sample and try
to find the best settings using their in-house secret algo.
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Expet: |ATR_LTDAUTF_GOLD a5 ~| |1oe @
Symbol: [XAUUSD v| [M20 v| (B
Date: |Custom period v | [2018.01.01 B~ | 2020917 B
Delays 23m‘i - . o emulste sippage and requotes duing trade execution
Madeling  Opan prices oy ~ | [ profit in pips for faster calculations

Degost: [10000 “]fuso ] T

Optimization: | Fast genetic based algorthm ~ | | Profit Factormax ~

Strategy Tester

erview | Settings I nputs | Backtest | Graph | Optimizzation Results | Agents | Joumnal Tof T - D016 /7 00:00:18 Start

Choose Symbol and the Chart Period you would have placed the Expert Advisor on, if it were live
trading.

X

The Yellow Dollar sign Icon is very important, to new users of MT5 strategy tester.

You will need to click on this Icon, to change the selected Symbols’ defaults for a correct back test.
Its” default is either; (No Leverage) ‘CFD’ and ‘Forex No Leverage’. Here you will change it to ‘CFD
Leverage’ or ‘Forex’.

87 Tested Symbol ? »

Symiol Nawsn & | 3
Common
Desapaon Gold vs US Dolar

1 Group path Commmodities Mo taks WALLISD

b Caregary
Exchange
Bass
Fage
o1 Digts 2
1 Base auency uso
Proft amency 0
Margin cumency uso
1 Sprend foatrg
91 Market depth £+
# Cartmode By e proc
Trade it
Y Contract size 10000000000 | [
4 Calaiaton D Leverage I
1 Shope level 0
| Freeze level o
Vi Tick siee 0.01
ok v 100000000
# Trade Full pccem
# Executon Maket
& GTC mode Good ol cancelled
& Fing Fil or K0, Tmadate o Cancel
& Boraton u
# Crders a
¥ Mimel voume 0.1
i Masmal vekame: 00
i Volume steg oo

Defait It Expert o ]| came

You can also change the default Direction from ‘Full Access’ to ‘Long only’ or Short Only’, this change
in direction set here, will only work for back tests and optimizations, this will not change in Live or
Demo trading.

Modelling Data: using Open Prices (the RTR Momentum Trend Expert is coded On Open Prices —
OnBar() ), or simulated ticks called ‘Every Tick’, ‘Every tick based on Real Ticks’ include Broker
historical Bid-Ask Spread, there is also a 1 minute bar option for the data.

Note: Back tests that have Real Tick selected will take a lot longer than on ‘Open prices’ modelling.
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| suggest Optimizations using ‘Open Prices’, then Run Single Back test using ‘Real Ticks’.

Start Step Stop Steps *
35535 1 555550
START, STEP, STOP:

START, is the first value of the input that will be tested.

STEP, is the increment, it will add to the previous value of the input that was tested, and will run a
new test.

STOP, is the Last value of the input that will be tested for.

So in this Example we have selected only 1 input for Optimization, Profit Threshold.
We Start at 8, STEP (increment)= 2, FINISH at 20.

We will test Profit Threshold at; 8, 10, 12, 14, 16, 18, 20.

And there are 7 Passes (8 to 20).

®]

Select expert_ ~ | View previous optimization results W
Variable Value Start Step Stop Steps ~ |
[ expertin Magic Number 671894 55555 55555
Time Frames, if 2 TF only, Middle Period will be ignored
[] 2 TimeFrames Only false false
[[] Highest Pericd 1 Day curment
[] Middle Period - ignored when 2 TimeFrames = true 1 Hour 1
[] Lowest Period - must attach EA to this chart 20 Minutes
Stop Lot Sizes
[} Fixed Lot size e.g 1.32 lots, ignored if ‘Risk %' is used 0.1 0.01
[ ‘Risk %' per Trade 1.00 = 1% Risk, 0.50 is half% 1.0 0
Fixed $Dollar Amount, Leave as 0 if not intended to use
[ Fixed SDollar Amount per Trade. o
- Take Profit Multiplier
Profit Threshold 104 8 2 20 7
Direction - Both, Long only, Short only
[ Direction Both Eath Short_On
Custom Trade Comment
[£] custom comment
Spread Filter
[] Maximurm Spread &0
Day of Week Filter
[] Sunday true fals tru
I Monday true fals tru
[ Tuesday true fals trus
[] Wednesday true fal
] Thursday true false true
[ Friday true false true
[ Saturday true fatse
g Hour of Day Filter
T [ Start operation hour 00:00
E ImEFT inn haye 2300 Or-0n F3.00 Ld
B Overvdiew | Settings | Inputs | Optimization Results | Agents | Journal 112 of 112 - 00:05:26 / 00:05:26 Stat |
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| Select expert.. || View previous optimization resuls v || Select orterion v
Pass = Result Profit Total trades Profit factor Expected payoff Drawdown % Recovery factor Sharpe ratio Profit_Threshold

o 51104.62 318 1.81 180.7 4.4 315 1.68 8

1 TO448.05 339 185 207.81 30.16 305 154 10

2 20326770 347 223 587.51 - 348 207 12

3 5224576 40 159 130.29 470 0.85 4

4 TO564.82 a7 1.59 169.22 4707 0.98 16

g 5 135499.55 438 1.74 308.66 4709 1.0 1.08 18
§ B 144 930m.N 434 144 205.00 4747 1.00 20
§ Oveview | Settings | Inputs | Optimization Results [ Agents | Journal Tof 7 - 00:00:11/00:00:11 [ Skad

Source: https://www.metatrader5.com/en/terminal/help/algotrading/strategy optimization

Retail Trading Realities Ltd
Company number 15221732

71-75 Shelton Street,
Covent Garden,
London, WC2H 9JQ,
United Kingdom

W: https://momentum-trend.com

E: contact@retailtradingrealities.com
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